Forum - Topic


Hey there~


Forum General talking Hey there~




2008-09-15 09:13:59

Good day~

I living in Asia under sunny weather ,and it's nice to driving

Wanna meet more friends here~

Cheers

Hill  
Jaroslav
2008-09-22 19:36:57

Welcome on the Middle-European Suzuki-site!

2008-11-08 19:13:19

i needs some help with a suziki vitara it lags power at top end an starts slow down any faster than 60 mph it feels like it is running out petrol but there is loads in the tank

Hill  
Jaroslav
2008-11-11 22:11:34

Although I know Swifts only, I try it: this seems to be like engine runs in the fail-safe mode.

1. test air filter, if clogged, clean, if possible, otherwise replace it

2. check spark plugs, clean electrodes and adjust spark gap to 0,8 mm (ca 1/32") each

3. in case you have classical distributor and high-voltage cables, test them for resistance (normally about 2,5 kiloohms per feet = 7 kilooms/meter of lenght). If one or more of cables has more, than 7 kiloohm per feet resp. 20 kiloohm/meter, eventually changes the resistance if moved, replace the cable immediately. Valid for cable coil->distributor too.

5. reset the ECM: ruán the engine to get normal temperature (70-90°C), switch engine off, then disconnect negative cable from battery, switch something on (i.ex. step on brake pedal for one half of minute) and connect the cable back to battery. Crank engine on and drive about 10 miles by your normally condition.

In case you do not will feel the difference, will be necessary to switch on (to) diagnostics.

Sorry, at the Vitara I do not know, how to make the diagnosis yourself...

Try to compare with manuals for GTi, here in the section "Manuals"


Reply